MAPIR CLOUD - Online Photogrammetry Platform - EARLY ACCESS OPEN NOW

Adding Camera Profiles to Pix4D to Improve Processing Results

Pix4D should have built in support for our MAPIR cameras, but sometimes you may need to improve the results. You can follow the below steps to add your own camera profile to the camera database:

Camera Profiles:

Kernel 1 - 3.2MP - 9.6mm Lens

Kernel 1 - 3.2MP - 3.5mm Lens

 

Survey3W - Visible Light (RGB)

Survey3W - OCN

Survey3W - RGN

Survey3W - NGB

Survey3W - RE

Survey3W - NIR

Survey3N - Visible Light (RGB)

Survey3N - OCN

Survey3N - RGN

Survey3N - NGB

Survey3N - NIR

Survey3N - RE

 

Survey2 - Visible Light (RGB)

Survey2 - NDVI (Red+NIR)

Survey2 - Infrared Light

Survey2 - Red Light

Survey2 - Green Light

Survey2 - Blue Light

 

Survey1 - Visible Light (RGB)

Survey1 - NDVI (Blue+NIR)

 

Steps to Add Custom Camera Profiles:

  1. With Pix4D open go to Help -> Settings -> Camera Database tab -> Export
  2. Save the camera database xml file somewhere on your computer.
  3. Open the xml file in a text editor like Notepad (should be able to just double-click to open, otherwise open your text editor and drag the file into the open editor window, File -> Open)
  4. Download the camera profile that corresponds to your modified camera.
  5. Open the xml camera profile in your text editor
  6. Copy the text from the <camera> to the </camera>
  7. On the camera database file that is open in your editor, paste the copied text after one of the other </camera> lines. If no </camera> lines exist, copy it after the <vendorId value="pix4d"/> line and before the </cameraModelDB> line.
  8. Save the camera database xml file
  9. Go to Help -> Settings -> Camera Database tab -> Import
  10. Select the modified camera database file
  11. Start a new project or open an existing one.
  12. Click the Camera icon (Image Properties Editor) at the top left of the main window. If this is a new project, go to the next step.
  13. Click the "View..." button under the "Selected Camera Model" section.
  14. Click the drop-down from the "Camera Model Name" and select the profile you have added, which should have a "user" icon (upper half of a person profile icon).
  15. Select the "OK" button at the bottom and run your project.

Any questions please let us know.




Nolan Ramseyer
Nolan Ramseyer

Author