7592 Metropolitan Drive
Suite 401
San Diego, CA USA
(877) 949 - 1684

Pre-Process Survey2 Images in Fiji with MAPIR Plugin

After you have captured your survey photos you will need to prepare your photos for your ortho-mosaic generation software. The steps below will explain how to do this for each camera:

  • Add GPS location to JPG images

  • Convert RAW to TIFF

  • Correct vignette of RAW and JPG images

RAW+JPG Mode [Recommended]:

The RAW & JPG images were saved in the Photo folder inside the DCIM folder of the SD card. We recommend you move the DCIM folder from the SD card to your computer hard drive to speed up processing times. Create a new folder inside the DCIM folder named something such as "Processed".

Inside the Photo folder move the JPG images to a separate folder from the RAW images. You can click on a JPG and in the View>Details layout click the Type column title to sort the folder by type to make selecting only the JPGs easier.

Extract the drone's flight controller log file:

Convert the log file to either a CSV, GPX or KML.

Download and install Geosetter. Apply the GPS locations from the log file to the JPG images, video guide HERE. Move the JPGs back to the Photo folder so the RAW and JPG images are together in the same order they were taken. Do not delete any photos yet if you plan to clean up the unnecessary photos (ascent, turns, descent).

Download our Fiji software package HERE that corresponds to the Windows OS you're using. Once the Fiji.app folder is downloaded and extracted run the ImageJ exe in the main folder.

Go to Plugins > MAPIR > Pre-Process Images From Directory

 

In the windows that pop up, choose the Photo folder as the input and the Processed folder as the output. The images will be processed as quickly as possible based on the speed of your computer. It may take awhile so please be patient. When the process is complete the log window will let you know it's complete. 

You are now ready to load the images into your ortho-mosaic generation software.

JPG Mode:

The JPG images were saved in the Photo folder inside the DCIM folder of the SD card. We recommend you move the DCIM folder from the SD card to your computer hard drive to speed up processing times. Create a new folder inside the DCIM folder named something such as "Processed".

Extract the drone's flight controller log file:

Convert the log file to either a CSV, GPX or KML.

Download and install Geosetter. Apply the GPS locations from the log file to the JPG images, video guide HERE. Do not delete any photos yet if you plan to clean up the unnecessary photos (ascent, turns, descent).

Download our Fiji software package HERE that corresponds to the Windows OS you're using. Once the Fiji.app folder is downloaded and extracted run the ImageJ exe in the main folder.

Go to Plugins > MAPIR > Post Process Images From Directory

In the windows that pop up, choose the Photo folder as the input and the Processed folder as the output. The images will be processed as quickly as possible based on the speed of your computer. It may take awhile so please be patient. When the process is complete the log window will let you know it's complete. 

You are now ready to load the images into your ortho-mosaic generation software.




Nolan Ramseyer
Nolan Ramseyer

Author